【AI】飞桨的简单使用及相关处理

By Heanny
2019-03-01
533 read

安装

安装介绍页面:https://www.paddlepaddle.org.cn/install/quick?docurl=/documentation/docs/zh/install/docker/linux-docker.html
安装所需版本即可,但是呢,好像目前2.2.2是只支持pythono3.8的,安装python其他版本会报错

  1. 安装前查看当前cpu的指令集知否支持avx,可以下载不同版本的whl文件进行安装
    https://www.paddlepaddle.org.cn/documentation/docs/zh/install/Tables.html
  2. 如果报错ModuleNotFoundError: No module named '_ctypes'则需要安装依赖
    (自己安装的python3.8版本可能会出现)
yum install libffi-devel
apt install libffi-dev
安装完之后重新make install即可
  1. docker安装
CPU版的PaddlePaddle,且镜像中预装好了 jupyter:
docker pull registry.baidubce.com/paddlepaddle/paddle:2.2.2-jupyter
用镜像构建并进入Docker容器:
docker run --name paddle -it -v $PWD:/paddle registry.baidubce.com/paddlepaddle/paddle:2.2.2 /bin/bash

#运行JupyterHub
docker run -p 80:80 --rm --env USER_PASSWD="password you set" -v $PWD:/home/paddle registry.baidubce.com/paddlepaddle/paddle:2.2.2-jupyter
  1. 验证
    安装完成后您可以使用 python 或 python3 进入python解释器,输入import paddle ,再输入 paddle.utils.run_check()

如果出现PaddlePaddle is installed successfully!,说明您已成功安装。

  1. import paddlehub报错及解决
from .cv2 import *
ImportError: libGL.so.1: cannot open shared object file: No such file or directory

apt install libgl1-mesa-glx

from .cv2 import *
ImportError: libgthread-2.0.so.0: cannot open shared object file: No such file or directory

apt-get install libglib2.0-dev

使用Docker启动PaddlePaddle Book教程

docker run -p 8888:8888 registry.baidubce.com/paddlepaddle/book
然后在浏览器中输入以下网址:

http://localhost:8888/

paddlehub demo

# 抠图 import paddlehub as hub humanseg = hub.Module(name='deeplabv3p_xception65_humanseg') results = humanseg.segmentation(data={'image':['./3.png']}, output_dir='./', visualization=True)
linux iptables 使用日常
php 神坑substr() mb_substr() mb_subcut区别与联系

Comments

暂无评论,还不快来坐沙发...

Leave a Reply