【笔记】记一次关于pip的问题

By Heanny
2018-10-30
1471 read

在你安装pip的时候可能会提示vc组件问题

error: Microsoft Visual C 14.0 is required. Get it with "Microsoft Visual

,这个直接下载安装visualcppbuildtools即可

如果还提示I$JQF5]WHZNF0}@)JF[T3}8.png

那么,前往

https://www.lfd.uci.edu/~gohlke/pythonlibs/#mysqlclient 下载相应的文件

即可




分割线


记ubuntu安装问题

pip install –upgrade setuptools -i http://pypi.douban.com/simple/

sudo apt-get install python-dev 

sudo apt-get install libssl-dev

sudo apt-get install libffi-dev

pip install cryptography

pip install enum

(pip --default-timeout=100 install cryptography)



依赖

pip install cryptography

pip install enum

pip install pymysql

pip install apscheduler

#解决没有 includ <python.h>

 

sudo apt-get install python-dev 

 

#解决UnicodeDecodeError: ascii codec cant decode byte 0xe5

import sys

reload(sys)

sys.setdefaultencoding('utf8')   

 

解决fatal error: 'ffi.h' file not found

brew install pkg-config libffi

export PKG_CONFIG_PATH=/usr/local/Cellar/libffi/3.0.13/lib/pkgconfig/

pip install bcrypt

  


安装scrapy报错:c/_cffi_backend.c:15:17: fatal error: ffi.h: No such file or directory

执行命令sudo apt-get install libffi-dev

 

 

 

fatal error: openssl/opensslv.h: 没有那个文件或目录

sudo apt-get install libssl-dev


【转】虚拟机VMware安装PhoenixOS(凤凰OS)
【php】设置php显示/隐藏错误信息

Comments

暂无评论,还不快来坐沙发...

Leave a Reply